Canada Post is reporting service disruptions
Incident Report for Fulfil.IO Inc.
Resolved
Canada Post is reporting the issue has now been resolved.

Label generation, rate lookups, voiding, manifesting, and other operations for the carrier should now work as expected. We will continue to monitor and update our status page, should we notice elevated response times or errors.
Posted Jul 04, 2022 - 16:39 EDT
Investigating
Canada Post is experiencing an outage that may prevent label generation, rate lookups, voiding, manifesting, and other operations for the carrier. Other carriers and services are **not** affected.

We recommend using an alternate service to ship or wait for the carrier issue to be resolved (https://status.canadapost.ca/). We will update this status page as we have more updates.
Posted Jul 04, 2022 - 11:40 EDT
This incident affected: Shipping Carriers (Canada post).