Shippo: Degraded Service Performance
Incident Report for Fulfil.IO Inc.
Resolved
Shippo is reporting their systems are operational again. Label generation and tracking updates should work as expected.
Posted Apr 24, 2024 - 11:42 EDT
Investigating
Shippo is currently reporting issues related to label creation and tracking updates. They are actively investigating.

Further updates can be tracked on their status page: https://status.goshippo.com/
Posted Apr 24, 2024 - 09:52 EDT
This incident affected: Shipping Carriers (USPS (Shippo)).