Shippo label generation is failing

Incident Report for Fulfil.IO Inc.

Resolved

Shippo is reporting label generation is operational again. https://status.goshippo.com/
Posted Feb 22, 2024 - 12:26 EST

Identified

Label generation with Shippo is currently unavailable due to an outage on their end. The issue has been identified and is being looked into.

For further updates, please follow: https://status.goshippo.com/
Posted Feb 22, 2024 - 11:47 EST
This incident affected: Shipping Carriers (USPS (Shippo)).