Easypost is currently reporting a major outage on their system backend
Incident Report for Fulfil.IO Inc.
Resolved
EasyPost has reported the system has recovered and all actions should be operational again.
Posted May 04, 2023 - 17:41 EDT
Investigating
Rating, tracking updates, and label generation may all be affected. We advise merchants to switch to a different carrier if any shipments need to urgently be fulfilled.

We are monitoring for further updates.
Posted May 04, 2023 - 16:31 EDT
This incident affected: Shipping Carriers (USPS (EasyPost)).